Autor Thema: SMTP_Client Alias-Name Fehler  (Gelesen 7735 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline skateman

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
SMTP_Client Alias-Name Fehler
« am: 27. August 2012, 15:40:00 »
Ich hatte bisher zum Versenden von mails immer einen GMX-Account verwendet, was auch gut funktionierte.

Nun habe ich aber einen Mail-Account eines anderen Providers verwendet und bei jedem Sende-Versuch die Fehlermeldung '555 5.5.4 unsupported option: <emailadresse@xyzaccount.at>' erhalten, was ich mir nicht erklären konnte, da alle Daten stimmten.

Durch googeln und diverse Versuche habe ich den Fehler nun gefunden:
Das Problem liegt am Alias-Namen --> diesen gibt man ja durch Trennung mit ";" an --> z.B. oscat@gmx.net;Station_01. Der SMTP_Client baut daraus dann folgenden String: 'MAIL FROM: "Station_01" <oscat@gmx.net>'.
Aus irgendeinem Grund mag der Mailserver das Leerzeichen zwischen Alias-Name und Mail-Adresse nicht - ich habe dieses mal entfernt und siehe da, es funktioniert --> 'MAIL FROM: "Station_01"<oscat@gmx.net>'

Vielleicht sollte man das mal ändern...



Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 377
    • Profil anzeigen
Re: SMTP_Client Alias-Name Fehler
« Antwort #1 am: 27. August 2012, 15:45:34 »
hallo

ich werde das nochmals testen, und wenn es passt, dann auch so uebernehmen

danke..
« Letzte Änderung: 27. August 2012, 15:47:16 von peewit »

Offline skateman

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
Re: SMTP_Client Alias-Name Fehler
« Antwort #2 am: 27. August 2012, 15:48:30 »
zwischen "Station_01" und <oscat@gmx.net>

"Station_01" <oscat@gmx.net> --> FALSCH
"Station_01"<oscat@gmx.net> --> RICHTIG