Autor Thema: Wago 750-843 und CUNO mit FW 1.44  (Gelesen 61113 mal)

0 Mitglieder und 2 Gäste betrachten dieses Thema.

Offline gravieren

  • Entwickler
  • *****
  • Beiträge: 578
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #30 am: 20. März 2012, 21:40:02 »
Hi Mail
Hallo,

wollte nur sagen das ich zur Zeit leider keine Zeit habe, da ich Privat Stress habe :(

Werde mich aber wieder melden  ;D Danke!
Kein Problem.
Stress hat ja jeder mal.  (Ob im Beruf oder Privat)

Gruß Karl

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #31 am: 22. März 2012, 20:13:31 »
Tach,

ja Stress hat jedermal, wollte nur kurz bescheid geben. Findes es selber nicht so toll, wenn sich die Leute dann nicht mehr melden.

MfG
Mike

PS Allen asb Morgen eine schönes WE  8)

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #32 am: 29. April 2012, 15:13:36 »
Hallo zusammen.

So wollte jetzt wieder mal etwas machen, hoffe das ich jetzt dafür Zeit finde ;)

Habe inzwischen eine WAGO 880, also dachte ich das mein Speicher Problem sei weg, naja war wohl nichts.

Wenn ich das Projekt übersetzte, bekomme ich ne Meldung "Anzahl der Bausteine 1023 überschritten.....".

Habe zur Zeit nur einen Baustein zum testen (zwei Eingänge 1, dann Ausgang 1).

Als Bibilotheken habe ich folgende:
oscat basic
oscat building
oscat network
Standard.lib
SysLibSockets.lib
SysLibFile.lib
SysLibCallback.lib

Kann ich nur 1023 Baustein einbinden, das wäre aber nicht gerade viel, oder? Wenn ich den Wert erhöhe kann ich das Projekt nicht mehr in die Wago laden.

Gruß Maik

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #33 am: 29. April 2012, 15:33:55 »
Habe jetzt mal die Mirco genommen und ohne oscat building.
So kann ich das Projekt jetzt übersetzen, aber toll finde ich das so noch nicht, da ich die building ja verwenden wollte.

Also  Projekt ist jetzt gestartet ohne Fehlermeldung, jetzt müsste ich wissen wo ich den emfangenden Werte her bekomme

r_time wird hoch gezählt wenn ich an der Fernbedienung ne Taste drücke. Also sollte etwas empfangen werden.

Gruß Maik
« Letzte Änderung: 29. April 2012, 17:29:07 von mfreye »

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #34 am: 29. April 2012, 18:49:38 »
Das mit den Lib's habe ich jetzt im Griff, hoffe ich ;)

Habe die Anzahl hoch gesetzt bekommen wie hier beschrieben: http://www.oscat.de/community/index.php?topic=1199.0

Gruß Maik

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #35 am: 06. Mai 2012, 15:38:35 »
Hallo,

kann mir da jemand weiter helfen?

Danke!

MfG
Maik

Offline mfreye

  • Jr. Member
  • **
  • Beiträge: 65
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #36 am: 09. Mai 2012, 18:30:47 »
Hallo,

anbei mal mein Testprojekt.

Gruß
Maik

[gelöscht durch Administrator]

matt

  • Gast
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #37 am: 10. September 2012, 08:36:12 »
Hallo,
der Vollständigkeit halber wollte ich auf dieses (meine) Seite hinweisen: http://www.cunolib.de
Dort steht die cunolib Bibliothek zum Download bereit. Die Bibliothek ermöglich z.Z. das Empfangen von FHT80b und FS20 Signalen via CUNO. Der FS20 Teil ist kürzlich auf die Anregung von mfreye/Maik entstanden.
Gruß
matt

Offline gravieren

  • Entwickler
  • *****
  • Beiträge: 578
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #38 am: 10. September 2012, 11:27:20 »
Hallo Matt
der Vollständigkeit halber wollte ich auf dieses (meine) Seite hinweisen: http://www.cunolib.de
Dort steht die cunolib Bibliothek zum Download bereit. Die Bibliothek ermöglich z.Z. das Empfangen von FHT80b und FS20 Signalen via CUNO. Der FS20 Teil ist kürzlich auf die Anregung von mfreye/Maik entstanden.

Danke das du diese LIB zur Verfügung stellst.

Wünschenwert wäre noch:
- Example als *.PRO   (Aufruf IP_CONTROL2,  Task z.b. Prio 2    Zyklisch  100ms  --> So läuft CUNO zumindestens bei mir)
- Anzeige-String was empfangen wurde, nur für den Anfang.  (Bei CUNO_Receiver)
  Z.b. -->   BeString := BUFFER_TO_STRING(ADR(R_BUF.BUFFER),R_BUF.SIZE,0, R_BUF.SIZE - 1);

Frage: Hast du mit dem 1-Wire bereits Erfahrungen ?


Danke

Möge deine LIB noch viele Updates und Erneuerungen bekommen.


P.S.: Ich bin ein TOTALER CUNO-Anhänger !

Gruß Karl

Offline gravieren

  • Entwickler
  • *****
  • Beiträge: 578
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #39 am: 10. September 2012, 11:34:37 »
Hallo

Möglicherweise Interessant für mache User !

MAX! von ELV.
http://www.elv.de/max-cube-lan-gateway.html


Wird jetzt von CUNO unterstützt.
https://groups.google.com/forum/#!topic/cul-fans/lWlGtYL3RNU

Gruß Karl

matt

  • Gast
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #40 am: 10. September 2012, 13:15:08 »
Hey,

- Example als *.PRO   (Aufruf IP_CONTROL2,  Task z.b. Prio 2    Zyklisch  100ms  --> So läuft CUNO zumindestens bei mir)
Da haben mich jetzt schon mehrere Leute drauf angesprochen, muß ich wohl mal machen.

- Anzeige-String was empfangen wurde, nur für den Anfang.  (Bei CUNO_Receiver)
  Z.b. -->   BeString := BUFFER_TO_STRING(ADR(R_BUF.BUFFER),R_BUF.SIZE,0, R_BUF.SIZE - 1);
Das ist ein guter Gedanke, wird in die nächste Version implementiert.

Frage: Hast du mit dem 1-Wire bereits Erfahrungen ?
Nein, ich habe keinerlei 1-Wire Gerätschaften. Was gibt es denn da so?

P.S.: Ich bin ein TOTALER CUNO-Anhänger !
Ich auch!

Gruß
matt

Offline gravieren

  • Entwickler
  • *****
  • Beiträge: 578
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #41 am: 10. September 2012, 15:26:43 »
Hi

>Nein, ich habe keinerlei 1-Wire Gerätschaften. Was gibt es denn da so?
Sinnvoll sind z.b. Temperatursensoren.
D.h.   1 Kabel  mit 3 Adern, da kann man theoretischer weise 20-50 Sensoren parallel dranhängen. 

Z.b Temperatursensoren --> Digital --> Preis ca.   1,90 Euro  --> (  DS18B20+ ...)  -->       http://www.fuchs-shop.com/de/shop/5/

Also mal im Heizungskeller 20 Temperaturen messen -->  40 Euro  !
(Temperaturen werden Digital eingelesen)

Oder 4 Stück Analoge Werte einlesen -->  DS2450S+   --> 4,80 Euro



Kurzinfos zu 1-Wire  --> http://www.1-wire.de/oxid/1-Wire-BUS-System/



Gruß Karl

matt

  • Gast
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #42 am: 10. September 2012, 16:10:47 »
Liest sich ja ganz gut. Letzte kleine Frage: Hast Du da Softwarekomponenten für?
OneWire<->CUNO<->SPS

Offline martin.k

  • Entwickler
  • *****
  • Beiträge: 177
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #43 am: 10. September 2012, 16:15:51 »
Hi
Die Kette 1-Wire -> Cuno -> Ethernet -> CoDeSys würde mich auch interessieren...
Ich fummel gerade mit der Kette 1-Wire -> Koppler von eservice -> Serielle Schnittstelle der 750-841 -> Lib von Enra -> CoDeSys rum und bekomme es nicht zum laufen.

Gruß
Martin

Offline gravieren

  • Entwickler
  • *****
  • Beiträge: 578
    • Profil anzeigen
Re: Wago 750-843 und CUNO mit FW 1.44
« Antwort #44 am: 10. September 2012, 16:22:29 »
Hi

Liest sich ja ganz gut. Letzte kleine Frage: Hast Du da Softwarekomponenten für?
OneWire<->CUNO<->SPS

Leider nein.

CUNO<->SPS   --> Identisch

Du benötigst nur noch einen "zusätzlichen Softwarebaustein".


Schau doch mal hier:   http://culfw.de/commandref.html
Protocol Part 1 --> "F" --> FS20-Geräte
Protocol Part 1 --> "O" --> One Wire


Bei Interesse für das Thema:   Ich könnte dir 2 Sensoren Typ DS18S20 zukommen lassen.  ( Kostenlos )


Falls ja, sende mir deine Adresse als E-Mail.  ( Oder als PM hier im Forum )


Gruß Karl