Autor Thema: SMTP_Client ohne Error aber kein Email ?!  (Gelesen 8010 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Omalik

  • Full Member
  • ***
  • Beiträge: 110
  • Phantasie ist wichtiger als Wissen, denn Wissen
    • Profil anzeigen
    • Home Cinema Pro - Heimkinosteuerungen
SMTP_Client ohne Error aber kein Email ?!
« am: 06. Dezember 2013, 17:02:26 »
SMTP_Client ohne Error aber kein Email ?!

Ich benutze den SMTP_Client Baustein mir dem Oscat Test Email Account. Alle funktioniert bestens. Nun habe ich den Server uws. auf meine Email Adresse geändert. Nun kann ich den Actvate auf True setzen. Busy Geht auf True und nach einer gewissen Zeit auch Done. Kein Error_t oder error_c. Doch ich bekomme keine Emails mehr. Kenn jemand das Problem.

Geändert habe ich den server, mailfrom. Rest habe ich so stehen gelassen wie es mit dem Testaccoung von Oscat funktionierte.  Würde gerne mein Email Adresse verwenden und nicht das Email Test Account von Oscat.

PS: Wenn ich ein falsches Passwort eingebe kommt eine Fehlermeldung wie erwartet.


Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 378
    • Profil anzeigen
Re: SMTP_Client ohne Error aber kein Email ?!
« Antwort #1 am: 06. Dezember 2013, 18:16:51 »
hi

also wenn der baustein mit "done" beendet , dann werden auch alle abfolgen / schritte korrekt durchlaufen (ziemlich sicher!)
der email server akzeptiert zwar alles, aber vielleicht gibt es einen logische fehler !

kannst du mir deine parameter senden
am besten eine bildschrimhardcopy im online status so dass man alle parameter sehen kann

du kannst mir das auch als private nachricht schicken

Offline Omalik

  • Full Member
  • ***
  • Beiträge: 110
  • Phantasie ist wichtiger als Wissen, denn Wissen
    • Profil anzeigen
    • Home Cinema Pro - Heimkinosteuerungen
Re: SMTP_Client ohne Error aber kein Email ?!
« Antwort #2 am: 11. Dezember 2013, 21:18:06 »
GELÖST: Die Oscat Lib funktioniert einwandfrei. Das Problem bei mir war, dass ich das Email an 3 Email Adressen schicken muss. Eine ist auch die Email Adresse, die die SPS zum Senden benutzt. Das wurde von meinem Provider, warum auch immer nicht zugelassen. (Aus dem Outlook heraus geht es)
Auch mit den Sonderzeichen hatte ich so meine Erfahrung machen müssen. Da aus Sicherheitsgründer Gross und Kleinbuchstaben, eine Zahl und ein Sonderzeichen Pflicht ist. Ich verwende nun das  - (minus Zeichen) als Sonderzeichen. Nun mach die SPS genau das was ich wollte. Besten Dank an peewit