Autor Thema: SMTP_CLIENT ohne DNS  (Gelesen 3318 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline rrbd

  • Full Member
  • ***
  • Beiträge: 146
    • Profil anzeigen
    • E-Mail
SMTP_CLIENT ohne DNS
« am: 06. Januar 2014, 20:08:13 »
Moin,

nun habe ich mit einer Phoenix ILC 155 erstmals (den ansonsten Häufigeren) Fall, dass der Mailserver einfach eine IP-Adresse und keinen Namen hat, dafür keine Authentifizierung benötigt. Etwas ratloses herumprobieren brachte mich nicht weiter, Müsste mal die Fehlermeldungen untersuchen:
ERROR_C: 006401F5
ERROR_T: 05
kam noch nicht dazu.

Deshalb meine Frage: Was muss ich gegenüber der Gewohnten" Beschaltung an 'DNS_IP4' (und evtl. bei 'SERVER') ändern, damit das funktioniert? Hinweis: Aus dem Netzsegment mit der SPS kommt man nicht in's Internet.

Danke schon mal für Rat und Hilfe

Rainer
« Letzte Änderung: 06. Januar 2014, 22:51:20 von rrbd »

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 282
    • Profil anzeigen
Re: SMTP_CLIENT ohne DNS
« Antwort #1 am: 06. Januar 2014, 22:13:43 »
wenn die angabe bei server eine direkte ip-adresse ist (wie z.b.server ='192.168.0.1' dann wird vom baustein auch keine dns abfrage durchgeführt

so einfach ist das

Offline rrbd

  • Full Member
  • ***
  • Beiträge: 146
    • Profil anzeigen
    • E-Mail
Re: SMTP_CLIENT ohne DNS
« Antwort #2 am: 06. Januar 2014, 22:53:41 »
Hallo,

habe ich so vermutet, allerdings klappt's nicht.
Momentan habe ich an

SERVER:  '180.0.0.91'
DNS_IP4: '8.8.8.8' über IP4_DECODE
MAILFROM: Die vorgegebene Absender-Emailadresse.

Hatte bisher keine Gelegenheit, das vor Ort mal per PC auszuprobieren, vielleicht teste ich das erst mal - man weiß ja nie!

Ist denn wenigstens die Syntax so richtig? Die (Zahlendreher im Posting korrigiert) Fehlermeldung 501 "Syntax-Fehler - Parameter oder Argument falsch" scheint mir aber eher auf einen Unverdaulchen Parameter aus SMTP_CLIENT hinzudeuten, möglicherweise wg. falscher Angaben des Betreibers, vielleicht aber auch, weil ich SMTP_CLIENT falsch benutze.

Gruß

Rainer

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 282
    • Profil anzeigen
Re: SMTP_CLIENT ohne DNS
« Antwort #3 am: 07. Januar 2014, 10:10:19 »
der fehler 501 kommt ja schon vom server selber, somit funktioniert die ip-adresse sehr wohl
jedoch gibt es noch irgendein anderes problem !

Offline rrbd

  • Full Member
  • ***
  • Beiträge: 146
    • Profil anzeigen
    • E-Mail
Re: SMTP_CLIENT ohne DNS
« Antwort #4 am: 15. Januar 2014, 07:49:43 »
Moin, mein Problem hatte wohl nichts mit dem OSCAT SMTP_CLIENT zu tun.

Mir ist eingefallen, dass ich schon seit ein paar Monaten in einem anderen Projekt eine Konfiguration ohne Authentifizierung laufen habe, kurzer Blick in das Projekt zeigte, dass dort der SMTP_CLIENT-Client-Eingang "DNS_IP4" unbeschaltet ist, was mir aber PCWORX EXPRESS im aktuellen Projekt aus unbekannten Gründen mit Fehlermeldung verweigerte. Daher die eigentlich sinnlose Beschaltung.

Im Aktuellen Projekt Arbeitsblatt für Mailversand gelöscht, aus funktionierendem Projekt kopiert, erforderlichen kleinen Anpassungen durchgeführt, läuft! Manchmal ...

Gruß

Rainer

Offline WilliamKristen

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Re: SMTP_CLIENT ohne DNS
« Antwort #5 am: 27. November 2018, 05:59:42 »
l per PC auszuprobieren, vielleicht teste ich das erst mal -