Autor Thema: Meter_Stat verliert die Daten nach Neustart (Phönix)  (Gelesen 8740 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

osi7

  • Gast
Meter_Stat verliert die Daten nach Neustart (Phönix)
« am: 13. Dezember 2014, 17:27:30 »
Hallo ;)
Ich möchte auch den Meter_Stat Baustein bei meiner Phönix RFC430 SPS einsetzen. Das mit dem Datum hat dank dem Beitrag von Peewit  super geklappt.
Ich habe jetzt aber auch das Problem, so wie manch anderer auch, dass nach einem Start-Stop der SPS alle gespeicherten Werte verloren sind.
Schuld ist meiner Meinung auch die Datums Variable. Der Baustein setzt angeblich die Werte auf null wenn das aktuelle Datum kleiner ist als das zuletzt im Baustein gespeicherte.
Ich habe den Aufbau schon so geändert, dass ich nur mehr in einem Netzwerk arbeite. Zuerst lese ich mit dem Baustein UhrRFC die Daten aus der SPS und gebe sie an  den Set_Date Bausteine weiter. Am Schluss befindet sich dann der   Meter_Stat Bausteine. Aber leider alles ohne Erfolg, nach Neustart wieder alle weg.

Die letzte Hoffnung war eine Sprungmarke mit der ich den Baustein einfach übersprungen bin so lange der Wert in der Datumvariable nicht grösser als 14000000000.. war hat aber auch nicht geklappt.
Meine I/O Variablen sind alle Retain und Redundant  deklariert.

Vielleicht habt ihr ja noch einen Tip.

Danke

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 371
    • Profil anzeigen
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #1 am: 14. Dezember 2014, 07:27:18 »
stell mal deinen baustein online


osi7

  • Gast
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #2 am: 15. Dezember 2014, 05:02:22 »
Hallo peewit  ;)
Danke erstmals, dass du dich wieder so schnell eingeschalten hast.
So sieht es momentan aus: Ich habe nach langen hin und her jetzt doch einen Kaltstart am RFC durchgeführt und dadurch meine anderen Zählwerte verloren. Aber seit dem Kaltstart funktioniert der Meter_Stat Baustein zumindest bei Warmstart einwandfrei.
Anscheinend muss man beim RFC doch hin und wieder einen Kaltstart durchführen damit er richtig arbeitet. Das wirft nun das nächste Problem auf. Gibt es beim RFC eine Möglichkeit wie man die Daten auch bei Kaltstart erhalten kann???

Aktuell versuche ich gerade den Baustein File_Read_Write am RFC zum Laufen zu bringen, sieht aber auch nicht gut aus habe aktuell 36 Fehler. Ist glaube ich nur für den ILC gedacht. Aber mal schauen!

Firmware POE 'FILE_READ' nicht gefunden! Wahrscheinlich nicht implementiert für Prozessortyp 'RFC430ET'.
Firmware POE 'FILE_OPEN' nicht gefunden! Wahrscheinlich nicht implementiert für Prozessortyp 'RFC430ET'.
Firmware POE 'FILE_CLOSE' nicht gefunden! Wahrscheinlich nicht implementiert für Prozessortyp 'RFC430ET'.
Firmware POE 'FILE_WRITE' nicht gefunden! Wahrscheinlich nicht implementiert für Prozessortyp 'RFC430ET'.
Parameter 'FILE_OPEN_1.Execute' nicht gefunden!
Parameter 'FILE_OPEN_1.Name' nicht gefunden!
Parameter 'FILE_OPEN_1.Done' nicht gefunden!
Parameter 'FILE_OPEN_1.Handle' nicht gefunden!
Parameter 'FILE_OPEN_1.Error' nicht gefunden!
Parameter 'FILE_OPEN_1.ErrorID' nicht gefunden!
Parameter 'FILE_CLOSE_1.Execute' nicht gefunden!
Parameter 'FILE_CLOSE_1.Handle' nicht gefunden!
Parameter 'FILE_CLOSE_1.Done' nicht gefunden!
Parameter 'FILE_CLOSE_1.Error' nicht gefunden!
Parameter 'FILE_CLOSE_1.ErrorID' nicht gefunden!
Parameter 'FILE_READ_1.Execute' nicht gefunden!
Parameter 'FILE_READ_1.Handle' nicht gefunden!
Parameter 'FILE_READ_1.Buffer' nicht gefunden!
Parameter 'FILE_READ_1.MaxLength' nicht gefunden!
Parameter 'FILE_READ_1.Done' nicht gefunden!
Parameter 'FILE_READ_1.LengthRead' nicht gefunden!
Parameter 'FILE_READ_1.Buffer' nicht gefunden!
Parameter 'FILE_READ_1.Error' nicht gefunden!
Parameter 'FILE_READ_1.ErrorID' nicht gefunden!
Parameter 'FILE_WRITE_1.Execute' nicht gefunden!
Parameter 'FILE_WRITE_1.Handle' nicht gefunden!
Parameter 'FILE_WRITE_1.Buffer' nicht gefunden!
Parameter 'FILE_WRITE_1.Length' nicht gefunden!
Parameter 'FILE_WRITE_1.Done' nicht gefunden!
Parameter 'FILE_WRITE_1.LengthWritten' nicht gefunden!
Parameter 'FILE_WRITE_1.Buffer' nicht gefunden!
Parameter 'FILE_WRITE_1.Error' nicht gefunden!
Parameter 'FILE_WRITE_1.ErrorID' nicht gefunden!

Wie löst ihr die Probleme mit dem Kaltstart???

Danke
LG
Osi7


[gelöscht durch Administrator]

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 371
    • Profil anzeigen
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #3 am: 15. Dezember 2014, 18:21:10 »
was für einen rfc hast du

firmware / Hardware
pcworx version

die rfc ist wahrscheinlich schon sehr alt und setzt noch auf einen vxworks kern, und der ist nicht kopatibel zu den file und ethernet bausteinen.


kaltstart ist nunmal dazu da um auch alle remanten variablen zu löschen.
alles richtig.

warum machst du denn einen kaltstart ?

 
« Letzte Änderung: 15. Dezember 2014, 18:33:07 von peewit »

osi7

  • Gast
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #4 am: 16. Dezember 2014, 05:08:14 »
Ich hab eine RFC430, Version 30/4.6D/5.00 steht im Programm bzw. am Aufkleber auf der SPS steht 32/4.6A/5.20. Ich glaube ich habe vergangenes Jahr die 5.20 aufgespielt.
Die Steuerungen sind gut zehn Jahre alt.

Ich bin der Meinung und es wurde mir auch so gesagt, dass diese Steuerung von Zeit zu Zeit einen Kaltstart benötigt damit sie richtig arbeitet.
Nach dem Laden des Bootprojektes soll laut Vertreter unbedingt ein Kaltstart durchgeführt werden.

Jedenfalls wäre mir wohler wenn meine Zählerdaten noch irgendwo zusätzlich abgesichert wären.
Bis mir eine bessere Lösung einfällt, zeichne ich aktuell die Variablen mit einem Datenlogger in der Visu auf.

 8)

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 371
    • Profil anzeigen
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #5 am: 16. Dezember 2014, 06:44:46 »
Ich hab eine RFC430, Version 30/4.6D/5.00 steht im Programm bzw. am Aufkleber auf der SPS steht 32/4.6A/5.20. Ich glaube ich habe vergangenes Jahr die 5.20 aufgespielt.
Die Steuerungen sind gut zehn Jahre alt.

die ist zu den file und ethernet bausteinen nicht kompatibel


Ich bin der Meinung und es wurde mir auch so gesagt, dass diese Steuerung von Zeit zu Zeit einen Kaltstart benötigt damit sie richtig arbeitet.

das sollte normalerweise nicht sein !


Nach dem Laden des Bootprojektes soll laut Vertreter unbedingt ein Kaltstart durchgeführt werden.
das ist zumindest nicht direkt falsch

bei programmänderungen musst du aufpassen das du im ram und am flash änderst, ansonsten ist nach spannung aus/ein dein altes programm am laufen


Jedenfalls wäre mir wohler wenn meine Zählerdaten noch irgendwo zusätzlich abgesichert wären.
Bis mir eine bessere Lösung einfällt, zeichne ich aktuell die Variablen mit einem Datenlogger in der Visu auf.

ist wahrscheinlich das einfachste und beste

osi7

  • Gast
Re: Meter_Stat verliert die Daten nach Neustart (Phönix)
« Antwort #6 am: 17. Dezember 2014, 04:46:42 »
Danke für die Info!!!  :'(