Autor Thema: NETWORK.lib unter Codesys 3.5 SP17 (x64) - Probleme mit SysFile23 & SysSocket23  (Gelesen 882 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline pmiller87

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Hallo Leute,

nach einigen Stunden Recherche, herumprobieren und der erfolglosen Suche nach Alternativen habe ich mich jetzt in diesem Forum angemeldet und hoffe auf Hilfe. Ich habe die NETWORK-Lib (1.3.5.2) über den Codesys Store heruntergeladen und installiert. Wie auch in den Requirements beschrieben erhalte ich beim Übersetzen meines Projekts die Fehlermeldung, dass die Bibliotheken sysfile23 3.5.13.0 und syssocket23 3.5.13.0 nur in 32-Bit-Applikationen unterstützt werden. Allerdings war die selbe Einschränkung auch bei der BASIC-Lib vorhanden, diese funktioniert allerdings einwandfrei (warum auch immer ???).
Gibt es denn irgendeine Möglichkeit, die NETWORK-Lib lauffähig zu kriegen? Die POUs die ich verwenden möchte, sind ausschließlich die Konverter. Vor allem benötige ich den BASE64_DECODE_STREAM, da ich BASE64 codierte Byteströme verarbeiten möchte. Ist es denn möglich, diese beiden Bibliotheken zu ersetzen? Die SysTypesInterfaces in der SysFile23 Bibliothek kenne ich z.B. aus der SysTypes2Interfaces aus einer Crypto-Lib, die problemlos läuft auf meinem System... 

Über Hilfestellungen wäre ich sehr dankbar! Ansonsten wünsche ich allen einen guten Rutsch heute ;)
« Letzte Änderung: 31. Dezember 2021, 15:28:44 von pmiller87 »

Offline mattsches

  • Sr. Member
  • ****
  • Beiträge: 264
    • Profil anzeigen
Wenn du nur Bausteine brauchst, die die erwähnten Bibliotheken nicht erfordern, dann ist es vermutlich das einfachste, die benötigten Bausteine aus der Bibliothek in dein Projekt oder in eine eigene Bibliothek zu kopieren. Nicht sehr elegant (wirklich nicht), aber vermutlich der pragmatischste Ansatz.

Offline peewit

  • Moderator
  • *****
  • Beiträge: 2 371
    • Profil anzeigen
Hallo

nachdem die oscat bibliotheken für codesys 3.x von codesys selber adaptiert wurden wäre es das sinnvollste wenn du dich mit deinem problem auch direkt an das codesys forum wendest.

es dürfte zumindest kein grundsätzliches problem sein das vom unseren original-bibliotheken ausgeht

du hast eventuell irgendwelche versionkonflikte von codesys und bibliotheksversion

https://forge.codesys.com/forge/talk/

Offline pmiller87

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Vielen Dank erstmal für die Antworten. Tatsächlich ist es so, dass die Bausteine die ich verwenden wollte, nicht auf die problematischen Bibliotheken zugreifen. Daher habe ich deinen Vorschlag (@mattsches) erfolgreich angewendet. Pragmatismus ist ja nicht immer schlecht ;)
@peewit: Falls ich in einem anderen Projekt doch nochmal auf dieses Problem zurückfalle, werde ich mein Problem im Codesys-Forum platzieren.
Auf jeden Fall vielen Dank für die Hilfe!